Some clients are not able to access their room

Incident Report for Evercast system status

Resolved

Your Evercast service should be up and running. We sincerely apologize for any inconvenience this may have caused you and your team.
Posted Jun 20, 2025 - 09:25 PDT

Identified

We have identified the cause of this issue to be a problem with how servers were assigning rooms. We've corrected the problem and are continuing to monitor to make sure that room access is working correctly.

If you experience any other difficulty with your room, please reach out to our 24/7 support team.
Posted Jun 20, 2025 - 09:24 PDT

Update

We are continuing to investigate this issue.
Posted Jun 20, 2025 - 09:17 PDT

Investigating

Some customers are experiencing trouble accessing their room and are getting stuck on the room loading screen. This issue started around 8:45 am PT.

We are actively investigating this issue and working on a solution. Thank you for your patience.
Posted Jun 20, 2025 - 09:16 PDT
This incident affected: Rooms Available.